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Question # 1
What Is Rational Robot?

Answer:-
Rational Robot is a complete set of components for automating the testing of Microsoft Windows client/server and Internet applications.
The main component of Robot lets you start recording tests in as few as two mouse clicks. After recording, Robot plays back the tests in a fraction of the time it
would take to repeat the actions manually.
Read More Answers.

Question # 2
How to create a verification point?

Answer:-
1.  Do one of the following:
      . If recording, click the Display GUI Insert Toolbar button on the GUI Record toolbar.
      . If editing, position the pointer in the script and click the Display GUI Insert Toolbar button on the Standard toolbar.
   2. Click a verification point button on the GUI Insert toolbar.
   3. In the Verification Point Name dialog box, edit the name as appropriate. The name can be a maximum of 20 characters.
   4. Optionally, set the Wait state options. For information, see the next section, Setting a Wait State for a Verification Point.
   5. Optionally, set the Expected result option.
   6. Click OK.
Read More Answers.

Question # 3
What is A verification point?

Answer:-
A verification point is a point in a script that you create to confirm the state of an object across builds of the application-under-test.
Read More Answers.

Question # 4
How to analyz results in the log and comparators?

Answer:-
You use TestManager to view the logs that are created when you run scripts and schedules.
Use the log to:
--View the results of running a script, including verification point failures, procedural failures, aborts, and any additional playback information. Reviewing the results
in the log reveals whether each script and verification point passed or failed.
Use the Comparators to:
--Analyze the results of verification points to determine why a script may have failed. Robot includes four Comparators:
.Object Properties Comparator
.Text Comparator
.Grid Comparator
.Image C omparator
Read More Answers.

Question # 5
What is datapool?

Answer:-
A datapool is a source of variable test data that scripts can draw from during playback.
Read More Answers.
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Question # 6
What is Rational Administrator?

Answer:-
Use the Rational Administrator to:
    * create and manage projects.
    * Create a project under configuration management.
    * Create a project outside of configuration management.
    * Connect to a project.
    * See projects that are not on your machine (register a project).
    * Delete a project.
    * Create and manage users and groups for a Rational Test datastore.
    * Create and manage projects containing Rational RequisitePro projects and Rational Rose models.
    * Manage security privileges for the entire Rational project.
    * Configure a SQL Anywhere database server.
Read More Answers.

Question # 7
What is TestFactory?

Answer:-
Rational TestFactory is a component-based testing tool that automatically generates TestFactory scripts according to the application's navigational structure.
TestFactory is integrated with Robot and its components to provide a full array of tools for team testing under Windows NT 4.0, Windows 2000, Windows 98, and
Windows 95.
With TestFactory, you can:
--Automatically create and maintain a detailed map of the application-under-test.
--Automatically generate both scripts that provide extensive product coverage and scripts that encounter defects, without recording.
--Track executed and unexecuted source code, and report its detailed findings.
--Shorten the product testing cycle by minimizing the time invested in writing navigation code.
--Play back Robot scripts in TestFactory to see extended code coverage information and to create regression suites; play back TestFactory scripts in Robot to debug
them.
Read More Answers.

Question # 8
TestManagers wizard?

Answer:-
TestManager has a wizard that you can use to copy or import test scripts and other test assets (Datapools) from one project to another.
Read More Answers.

Question # 9
How to delete a verification point and its associated files?

Answer:-
1.  Right-click the verification point name in the Asset (left) pane and click Delete.
   2. Click the top of the script in the Script (right) pane.
   3. Click Edit > Find.
   4. Type the name of the deleted verification point in the Find what box.
   5. Click Find Next.
   6. Delete the entire line, which starts with Result=.
   7. Repeat steps 5 and 6 until you have deleted all references.
Read More Answers.

Question # 10
How to rename a verification point and its associated files?

Answer:-
1.  Right-click the verification point name in the Asset (left) pane and click Rename.
   2. Type the new name and press ENTER.
   3. Click the top of the script in the Script (right) pane.
   4. Click Edit > Replace.
   5. Type the old name in the Find what box. Type the new name in the Replace with box.
   6. Click Replace All.
Read More Answers.

Question # 11
What is an identification method?

Answer:-
An identification method tells Robot how to identify the values to compare during record and playback.
Read More Answers.

Question # 12
What is verification method?
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Answer:-
The verification method specifies how Robot compares the baseline data captured while recording with the data captured during playback.
Read More Answers.

Question # 13
What are two verification points for use with Web sites?

Answer:-
1. Use the Web Site Scan verification point to check the content of your Web site with every revision and ensure that changes have not resulted in defects.
2. Use the Web Site Compare verification point to capture a baseline of your Web site and compare it to the Web site at another point in time.
Read More Answers.

Question # 14
How to add a wait state when creating a verification point?

Answer:-
1.  Start to create the verification point.
   2. In the Verification Point Name dialog box, select Apply wait state to verification point.
   3. Type values for the following options: Retry every - How often Robot retries the verification point during playback. Robot retries until the verification point
passes or until the timeout limit is reached.
      Timeout after - The maximum amount of time that Robot waits for the verification point to pass before it times out. If the timeout limit is reached and the
verification point has not passed, Robot enters a failure in the log. The script playback either continues or stops based on the setting in the Error Recovery tab of the
GUI Playback Options dialog box.
Read More Answers.

Question # 15
Verification point type?

Answer:-
Alphanumeric:
Captures and tests alphanumeric data in Windows objects that contain text, such as edit boxes, check boxes, group boxes, labels, push buttons, radio buttons, toolbars,
and windows (captions).
2. Clipboard:
Captures and compares alphanumeric data that has been copied to the Clipboard.
3. File Comparison:
Compares two specified files during playback.
4. File Existence:
Verifies the existence of a specified file during playback.
5. Menu:
Captures and compares the menu title, menu items, shortcut keys, and the state of selected menus.
6. Module Existence:
Verifies whether a specified module is loaded into a specified context (process), or is loaded anywhere in memory.
7. Object Data
Captures and compares the data inside standard Windows objects.
8. Object Properties
Captures and compares the properties of standard Windows objects.
9. Region Image
Captures a region of the screen as a bitmap.
10. Web Site Compare
Captures a baseline of a Web site and compares it to the Web site at another point in time.
11. Web Site Scan
Checks the contents of a Web site with every revision and ensures that changes have not resulted in defects.
12. Window Existence:
Verifies the existence and status of a specified window during playback.
13. Window Image:
Captures a window as a bitmap.
Read More Answers.

Question # 16
What is Rational SiteCheck?

Answer:-
Rational SiteCheck to test the structural integrity of your intranet or World Wide Web site. SiteCheck is designed to help you view, track, and maintain your rapidly
changing site. Use SiteCheck to:
    * Visualize the structure of your Web site and display the relationship between each page and the rest of the site.
    * Identify and analyze Web pages with active content, such as forms, Java, JavaScript, ActiveX, and Visual Basic Script (VBScript).
    * Filter information so that you can inspect specific file types and defects, including broken links.
    * Examine and edit the source code for any Web page, with color-coded text.
    * Update and repair files using the integrated editor, or configure your favorite HTML editor to perform modifications to HTML files.
    * Perform comprehensive testing of secure Web sites. SiteCheck provides Secure Socket Layer (SSL) support, proxy server configuration, and support for multiple
password realms.
Read More Answers.

Question # 17
How to create a datapool?
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Answer:-
When creating a datapool, you specify the kinds of data (called data types) that the script will send for example, customer names, addresses, and unique order
numbers or product names. When you finish defining the datapool, TestManager automatically generates the number of rows of data that you specify.
Read More Answers.

Question # 18
What two kind of GUI scripts using Rational Robot?

Answer:-
1. functional testing
2. sessions for performance testing.
    * Perform full functional testing. Record and play back scripts that navigate through your application and test the state of objects through verification points.
    * Perform full performance testing. Use Robot and TestManager together to record and play back sessions that help you determine whether a multi-client system is
performing within user-defined standards under varying loads.
    * Create and edit scripts using the SQABasic and VU scripting environments. The Robot editor provides color-coded commands with keyword Help for powerful
integrated programming during script development. (VU scripting is used with sessions in performance testing.)
    * Test applications developed with IDEs such as Java, HTML, Visual Basic, Oracle Forms, Delphi, and PowerBuilder. You can test objects even if they are not
visible in the application's interface.
    * Collect diagnostic information about an application during script playback. Robot is integrated with Rational Purify, Rational Quantify, and Rational
PureCoverage. You can play back scripts under a diagnostic tool and see the results in the log.
Read More Answers.

Question # 19
Which products does Rational Robot Installs with?

Answer:-
ClearQuest - Change-Request management tool that tracks and manages defects and change requests through the development process.
Rational LogViewer and Comparators- are the tools you use to view logs and test results created when you playback scripts.
Rational Robot - is the tool that you used to develop both GUI and VU (virtual user) scripts.
SQL Anywhere - A database product to help create, maintain and run your Rational repositories.
Rational Test Manager - is the component that you use to plan your tests, manage your test asses, and run queries and reports.
Rational Administrator - is the component that you use to create and manage repositories.
Rational SiteCheck - is the component that you use to test the structural integrity of your intranet or www site.
Additional Rational Products available only with Rational Suite TestStudio or PerformanceStudio:
Test Factory - Component based testing tool that automatically generates TestFactory scripts according to the applications navigational structure.
Diagnostic Tools
Rational Purify - is a comprehensive C/C++ run time error checking tool.
Rational Visual Quantify - is an performance profiler that provides performance analysis of a product, to aid in improving performance of the code.
Rational Visual PureCoverage - is a customizable code coverage analysis tool that provides detailed application analysis and ensure that all code has been exercised.
Performance Studio - Tool used for automating performance tests on client/server systems.
Read More Answers.

Question # 20
How to set the expected result when creating a verification point?

Answer:-
1. Start to create a verification point.
2. In the Verification Point Name dialog box, click Pass or Fail.
Read More Answers.

Question # 21
How to select the object to test?

Answer:-
1.  Start creating the verification point.
   2. In the Verification Point Name dialog box, type a name and cl ick OK to open the Select Object dialog box.
   3. Do one of the following:
      . Select Automatically close dialog box after object selection to have the Select Object dialog box close after you select the object to test.
      .Clear Automatically close dialog box after object selection to have the Select Object dialog box reappear after you select the object to test. You will need to click
OK to close the dialog box. To select a visible object directly from the application, continue with step 4. To select an object from a list of all objects on the desktop,
skip to step 5.
   4. To select a visible object directly from the application, drag the Object Finder tool over the object and release the mouse button.
   5. To select a visible or hidden object from a list of all objects on the Windows desktop, click Browse to open the Object List dialog box. Select the object from the
list and click OK.
Read More Answers.

Question # 22
Eight verification methods?

Answer:-
1. Case-Sensitive - Verifies that the text captured during recording exactly matches the captured text during playback.
   2. Case-Insensitive - Verifies that the text captured during recording matches the captured text during playback in content but not necessarily in case.
   3. Find Sub String Case-Sensitive - Verifies that the text captured during recording exactly matches a subset of the captured text during playback.
   4. Find Sub String Case-Insensitive - Verifies that the text captured during recording matches a subset of the captured text during playback in content but not
necessarily in case.
   5. umeric Equivalence - Verifies that the values of the data captured during recording exactly match the values captured during playback.
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   6. Numeric Range - Verifies that the values of the data captured during recording fall within a specified range during playback. You specify the From and To values
for the numeric range. During playback, the verification point verifies that the numbers are within that range.
   7. User-Defined and Apply a User-Defined DLL test function - Passes text to a function within a dynamic-link library (DLL) so that you can run your own custom
tests. You specify the path for the directory and name of the custom DLL and the function. The verification point passes or fails based on the result that it receives
back from the DLL function.
   8. Verify that selected field is blank - Verifies that the selected field contains no text or numeric data. If the field is blank, the verification point passes.
Read More Answers.

Question # 23
Is there four identification methods?

Answer:-
1. By Content - to verify that the recorded values exist during playback.
   2. By Location - to verify that the recorded values exist in the same locations during playback.
   3. By Title - to verify that the recorded values remain with their titles (names of menus or columns) during playback, even though the columns may have changed
locations.
   4. By Key/Value - to verify that the recorded values in a row remain the same during playback.
Read More Answers.

Question # 24
How to copy a verification point?

Answer:-
1.  Right-click the verification point in the Asset (left) pane and click Copy.
   2. In the same script or in a different script (in the same project), right-click Verification Points in the Asset pane.
   3. Click Paste to paste a copy of the verification point and its associated files into the project. If a verification point with that name already exists, Robot appends a
unique number to the name. You can also copy and paste by dragging the verification point to Verification Points in the Asset pane.
   4. Click the top of the Script (right) pane of the original script.
   5. Click Edit > Find and locate the line with the verification point name that you just copied.
   6. Select the entire line, which starts with Result=.
   7. Click Edit > Copy.
   8. Return to the script that you used in step 2. Click the location in the script where you want to paste the line. Click Edit > Paste.
   9. Change the name of the verification point to match the name in the Asset pane.
Read More Answers.

Question # 25
What is TestManager?

Answer:-
Rational TestManager is the one place to manage all testing activities--planning, design, implementation, execution, and analysis. TestManager ties testing with the
rest of the development effort, joining your testing assets and tools to provide a single point from which to understand the exact state of your project.
Test Manager supports five testing activities:
1. Plan Test.
2. Design Test.
3. Implement Test.
4. Execute Tests.
5. Evaluate Tests.
Read More Answers.

Question # 26
What is Test Requirements?

Answer:-
Test requirements are defined in the Requirement Hierarchy in TestManager. The requirements hierarchy is a graphical outline of requirements and nested child
requirements.
Requirements are stored in the requisite pro database. Requisite Pro is a tool that helps project teams control the development process by managing and tracking the
changes of requirements.
TestManager includes a baseline version of Requisite Pro. The full version with more features and customizations is available in the Rational Suite TestStudio.
Read More Answers.

Question # 27
How TestManager manage test logs?

Answer:-
When a robot scripts runs the output creates a test log. Test logs are managed now is the TestManager application. Rational now allows you to organize your logs into
any type of format you need.
You can create a directory structures that suites your need Create build names for each build version (or development) Create folders in which to put the build in.
Read More Answers.

Question # 28
What is ClearQuest?

Answer:-
Rational ClearQuest is a change-request management tool that tracks and manages defects and change requests throughout the development process. With
ClearQuest, you can manage every type of change activity associated with software development, including enhancement requests, defect reports, and documentation
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modifications.
With Robot and ClearQuest, you can:
-- Submit defects directly from the TestManager log or SiteCheck.
-- Modify and track defects and change requests.
-- Analyze project progress by running queries, charts, and reports.
Read More Answers.

Question # 29
How to modify or delete a custom class name?

Answer:-
1.  Click Tools > General Options, and then click the Object Mapping tab.
   2. From the Object type list, select the standard object type that is associated with the object class name. Robot displays the class names already available for that
object type in the Object classes list.
   3. From the Object classes list, select the name to modify or delete.
   4. Do one of the following:
      . To modify the class name, click Modify. Change the name and click OK.
      . To delete the object class mapping, click Delete. Click OK at the confirmation prompt.
   5. Click OK.
Read More Answers.

Question # 30
How to create a new object order preference?

Answer:-
1. In an ASCII editor, create an empty text file with the extension .ord.
   2. Save the file in the Dat folder of the project.
   3. Click To o l s > G UI R e c o r d O p t i o n s .
   4. Click the Object Recognition Order tab.
   5. From the Object order preferences list, select the name of the file you created.
   6. Change the method order to customize your preferences.
Read More Answers.

Question # 31
How to change the object order preference?

Answer:-
1. Open the GUI Record Options dialog box.
   2. Click the Object Recognition Order tab.
   3. Select a preference in the Object order preference list.
   4. Click OK or change other options.
Read More Answers.

Question # 32
Setting GUI Recording Options?

Answer:-
1. Open the GUI Record Options dialog box by doing one of the following:
--Before you start recording, click Tools > GUI Record Options.
-- Start recording by clicking the Record GUI Script button on the toolbar.
In the Record GUI dialog box, click Options.
2. Set the options on each tab.
3. Click OK.
Read More Answers.

Question # 33
Rational diagnostic tools?

Answer:-
Use the Rational diagnostic tools to perform runtime error checking, profile application performance, and analyze code coverage during playback of a Robot script.
    * Rational Purify is a comprehensive C/C++ run-time error checking tool that automatically pinpoints run-time errors and memory leaks in all components of an
application, including third-party libraries, ensuring that code is reliable.
    * Rational Quantify is an advanced performance profiler that provides application performance analysis, enabling developers to quickly find, prioritize and
eliminate performance bottlenecks within an application.
    * Rational PureCoverage is a customizable code coverage analysis tool that provides detailed application analysis and ensures that all code has been exercised,
preventing untested code from reaching the end-user.
Read More Answers.

Question # 34
TestManager can be used for Performance Testing?

Answer:-
Rational Testmanager is a sophisticated tool that can be used for automating performance tests on client/server systems. A client/server system includes client
applications accessing a database or application server, and browsers accessing a Web server.
Performance testing uses Rational Robot and Rational TestManager. Use Robot to record client/server conversations and store them in scripts. Use TestManager to
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schedule and play back the scripts. During playback, TestManager can emulate hundreds, even thousands, of users placing heavy loads and stress on your database
and Web servers.
Read More Answers.

Question # 35
What is RequisitePro?

Answer:-
Rational RequisitePro is a requirements management tool that helps project teams control the development process. RequisitePro organizes your requirements by
linking Microsoft Word to a requirements repository and providing traceability and change management throughout the project lifecycle.
Read More Answers.

Question # 36
How to set GUI recording option?

Answer:-
To set the GUI recording options:
1. Open the GUI Record Options dialog box by doing one of the following: . Before you start recording, click Tools > GUI Record Options. . Start recording by
clicking the Record GUI Script button on the toolbar. In the Record GUI dialog box, click Options.
2. Set the options on each tab.
3. Click OK.
Read More Answers.

Question # 37
How to Control Robot Responds to Unknown Objects?

Answer:-
1. Open the GUI Record Options dialog box.
2. In the General tab, do one of the following:
-- Select Define unknown objects as type Generic to have Robot automatically associate unknown objects encountered while recording with the Generic object type.
-- Clear Define unknown objects as type Generic to have Robot suspend recording and open the Define Object dialog box if it encounters an unknown object during
recording. Use this dialog box to associate the object with an object type.
3. Click OK or change other options.
Read More Answers.

Question # 38
How to defining an Object Class Mapping?

Answer:-
1. Identify the class name of the window that corresponds to the object. You can use the Spy++ utility in Visual C++ to identify the class name. You can also use the
Robot Inspector tool by clicking Tools > Inspector.
2. In Robot, click Tools > General Options, and then click the Object Mapping tab.
3. From the Object type list, select the standard object type to be associated with the new object class name.
Robot displays the class names already available for that object type in the Object classes list box.
4. Click Add.
5. Type the class name you identified in step 1 and click OK.
6. Click OK.
Read More Answers.

Question # 39
Modifying or Deleting a Custom Class Name?

Answer:-
1. Click Tools > General Options, and then click the Object Mapping tab.
2. From the Object type list, select the standard object type that is associated with the object class name.
Robot displays the class names already available for that object type in the Object classes list.
3. From the Object classes list, select the name to modify or delete.
4. Do one of the following:
- To modify the class name, click Modify. Change the name and click OK.
- To delete the object class mapping, click Delete. Click OK at the
confirmation prompt.
5. Click OK.
Read More Answers.

Question # 40
Restoring the Robot Main Window During Recording?

Answer:-
When Robot is minimized or is hidden behind other windows during recording, you can bring it to the foreground in any of the following ways:
. Click the Open Robot Window button on the GUI Record toolbar.
. Click the Robot button on the Windows taskbar.
. Use the hot key combination CTRL+SHIFT+F to display the window and CTRL+SHIFT+H to hide the window.
Read More Answers.
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Question # 41
Naming Scripts Automatically?

Answer:-
1. Open the GUI Record Options dialog box.
2. In the General tab, type a prefix in the Prefix box.
Clear the box if you do not want a prefix. If the box is cleared, you will need to type a name each time you record a new script.
3. Click OK or change other options.
The next time you record a new script, the prefix and a number appear in the Name box of the Record GUI dialog box.
In the following figure, the autonaming prefix is Test. When you record a new script, Test7 appears in the Name box because there are six other scripts that begin
with Test.
Read More Answers.

Question # 42
How to change the order of the object recognition methods for an object type?

Answer:-
1.  Open the GUI Record Options dialog box.
   2. Click the Object Recognition Order tab.
   3. Select a preference in the Object order preference list. If you will be testing C++ applications, change the object order preference to C++ Recognition Order.
   4. From the Object type list, select the object type to modify. The fixed set of recognition methods for the selected object type appears in the Recognition method
order list in its last saved order.
   5. Select an object recognition method in the list, and then click Move Up or Move Down. Changes made to the recognition method order take place immediately,
and cannot be undone by the Cancel button. To restore the original default order, click Default.
   6. Click OK. 
Important Notes:
. Changes to the recognition method order affect scripts that are recorded after the change. They do not affect the playback of scripts that have already been recorded.
. Changes to the recognition method order are stored in the project. For example, if you change the order for the CheckBox object, the new order is stored in the
project and affects all users of that project.
. Changes to the order for an object affect only the currently-selected preference. For example, if you change the order for the CheckBox object in the preference, the
order is not changed in the C++ preference.
Read More Answers.

Question # 43
How to define an object class and map an object type to it?

Answer:-
1.  Identify the class name of the window that corresponds to the object. You can use the Spy++ utility in Visual C++ to identify the class name. You can also use the
Robot Inspector tool by clicking Tools > Inspector.
   2. In Robot, click Tools < General Options, and then click the Object Mapping tab.
   3. From the Object type list, select the standard object type to be associated with the new object class name. Robot displays the class names already available for
that object type in the Object classes list box.
   4. Click Add.
   5. Type the class name you identified in step 1 and click OK.
   6. Click OK.
Read More Answers.

Question # 44
Pausing and Resuming the Recording of a Script?

Answer:-
To pause recording:
--Click the Pause button on the GUI Record toolbar. Robot indicates a paused state by:
----Depressing the Pause button.
----Displaying Recording Suspended in the status bar.
----Displaying a check mark next to the Record > Pause command.
To resume recording:
-- Click Pause again.
----Always resume recording with the application-under-test in the same state that it was in when you paused.
Read More Answers.

Question # 45
How to end the recording of a script?

Answer:-
Click the Stop Recording button on the GUI Record toolbar.
Read More Answers.

Question # 46
How to define script properties?

Answer:-
1.  Do one of the following:
      . If the script is open, click File > Properties.
      . If the script is not open, click File > Open > Script. Select the script and click the Properties button.
   2. In the Script Properties dialog box, define the properties. For detailed information about an item, click the question mark near the upper-right corner of the dialog
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box, and then click the item.
   3. Click OK.
Read More Answers.

Question # 47
How to code a script manually?

Answer:-
1.  In Robot, click File > New > Script.
   2. Type a script name (40 characters maximum) and, optionally, a description of the script.
   3. Click GUI.
   4. Click OK. Robot creates an empty script with the following lines:
      Sub Main
      Dim Result As Integer
      'Initially Recorded: 01/17/05 14:55:53
      'Script Name: GUI Script
      End Sub
   5. Begin coding the GUI script.
Read More Answers.

Question # 48
How to add a new action to an existing script?

Answer:-
1.  If necessary, open the script by clicking File > Open > Script.
   2. If you are currently debugging, click Debug > Stop.
   3. In the Script window, click where you want to insert the new actions. Make sure that the application-under-test is in the appropriate state to begin recording at the
text cursor position.
   4. Click the Insert Recording button on the Standard toolbar. The Robot window minimizes by default, or behaves as specified in the GUI Record Options dialog
box.
   5. Continue working with the application-under-test as you normally do when recording a script.
Read More Answers.

Question # 49
How to add a feature to an existing GUI script?

Answer:-
1.  If necessary, open the script by clicking File > Open > Script.
   2. If you are currently debugging, click Debug > Stop.
   3. In the Script window, click where you want to insert the feature. Make sure that the application-under-test is in the appropriate state to insert the feature at the
text cursor position.
   4. Do one of the following:
      - To add the feature without going into recording mode, click the Display GUI Insert Toolbar button on the Standard toolbar. The Robot Script window remains
open. - To start recording and add the feature, click the Insert Recording button on the Standard toolbar. The Robot window minimizes by default, or behaves as
specified in the GUI Record Options dialog box. Click the Display GUI Insert Toolbar button on the GUI Record toolbar.
   5. Click the appropriate button on the GUI Insert toolbar.
   6. Continue adding the feature as usual.
Read More Answers.

Question # 50
How to set and clear breakpoints?

Answer:-
1.  If necessary, open a script by clicking File > Open> Script.
   2. Place the pointer on the line where you want to set a new breakpoint or clear an existing breakpoint. You can only place a breakpoint on a line where an
SQABasic command is executed. Breakpoints on comments, labels, and blank lines are not supported. Also, there are a very few commands that do not support
breakpoints (for example, Dim and Sub).
   3. Click once to insert a blinking text cursor. (You can also highlight the entire line or any part of the line.)
   4. Click Debug > Set or Clear Breakpoint. If you set a breakpoint, Robot inserts a solid red circle in the left margin or highlights the line. If you clear a breakpoint,
Robot removes the circle or highlighting.
   5. If you set a breakpoint, click Debug > Go. Robot executes as far as the breakpoint, and then displays a yellow arrow in the left margin of that line or highlights
the line.
Read More Answers.

Question # 51
How to insert a timer while recording or editing a script?

Answer:-
1.  Do one of the following:
      . If recording, click the Display GUI Insert Toolbar button on the GUI Record toolbar. . If editing, position the pointer in the script and click the Display GUI
Insert Toolbar button on the Standard toolbar.
   2. Click the Start Timer button on the GUI Insert toolbar.
   3. Type a timer name (40 characters maximum) and click OK. If you start more than one timer, make sure you give each timer a different name.
   4. Perform the timed activity.
   5. Immediately after performing the timed activity, click the Stop Timer button on the GUI Insert toolbar.
   6. Select a timer name from the list of timers you started and click OK.
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Read More Answers.

Question # 52
How to insert a log message into a script during recording or editing?

Answer:-
1. Do one of the following:
. If recording, click the Display GUI Insert Toolbar button on the GUI Record toolbar.
. If editing, position the pointer in the script and click the Display GUI Insert Toolbar button on the Standard toolbar.
2. Click the Write to Log button on the GUI Insert toolbar.
After playback, you can view logs and messages using TestManager.
Read More Answers.

Question # 53
How to Choose Network Recording?

Answer:-
1.  Click Tools Tools Tools Tools > Session Record Options Session Record Options Session Record Options Session Record Options.
   2. Click the Method Method Method Method tab, and click Network recording Network recording Network recording Network recording.
   3. Optionally, click the Method:Network Method:Network Method:Network Method:Network tab, and select the client/server pair that you will record. The default
is to record all of the network traffic to and from your computer.
   4. Optionally, click the Generator Filtering Generator Filtering Generator Filtering Generator Filtering tab to specify the network protocols to include in the script
that Robot generates.
Read More Answers.

Question # 54
How to set up and use proxy recording?

Answer:-
#  Start Robot on the proxy computer.
# In the Proxy Administration dialog box, match up the proxy computer and port with each server to be used in the test.
# In the Method:Proxy Method:Proxy Method:Proxy Method:Proxy tab of the Session Record Options dialog box, match up each client with the server it will send
requests to. Be sure to specify the actual server and not the proxy computer.
# Configure each client to send requests to the proxy computer, not to the server. For example, if the client will be sending requests to an Oracle database, use the
Oracle client configuration software to specify the proxy computer's address and port number, not the server's.
# On each client computer, a tester should start the client application and navigate to the point where recording will begin.
# On the proxy computer, enable recording (File File File File > Record Session Record Session Record Session Record Session).
# With recording enabled, each tester at each client computer performs the transactions to record.
# When all transactions are complete, stop recording on the proxy computer.
Read More Answers.

Question # 55
How to create a proxy computer?

Answer:-
1.  Click Tools Tools Tools Tools > Session Record Options Session Record Options Session Record Options Session Record Options.
   2. Click the Method Method Method Method tab and make sure that Proxy recording Proxy recording Proxy recording Proxy recording is selected.
   3. Click the Method:Proxy Method:Proxy Method:Proxy Method:Proxy tab.
   4. Click Proxy Admin Proxy Admin Proxy Admin Proxy Admin.
   5. In Proxy:Port Proxy:Port Proxy:Port Proxy:Port, specify the proxy computer's port number. Note that Robot has already detected and specified the proxy
computer's name. You can specify any available port number. Avoid the well-known ports (those below 1024). If you specify a port number that is unavailable, Robot
prompts you for a new port number.
   6. In the Server:Port Server:Port Server:Port Server:Port list, select a server involved in the test.
   7. Click Create Proxy Create Proxy Create Proxy Create Proxy.
Read More Answers.

Question # 56
How to add a client or server computer?

Answer:-
If you are using network or proxy recording, and the computer that you want to use is not listed in the Method Network and Method Proxy tabs, you can add it to the
list.
   1. Click Tools > Session Record Options
   2. Click the Method:Network tab or Method:Proxy tab, depending on whether you are adding a computer for network or proxy recording.
   3. Click Manage Computers.
   4. Click New.
   5. In the Name box of the Computers group, type a name to associate with the network name of the computer that you are adding. You can assign any name up to
40 characters.
   6. Type the computer's network name.
   7. Optionally, click Ping to make sure that the network name you just typed is correct. If it is correct, -Successful Ping of network name- appears in the status bar.
   8. Select Client System to list this computer as a client. Select Server System to list this computer as a server. You can select both choices.
   9. Click Add.
  10. Take the following steps to use a port number with the network name. A port number is required for servers used in proxy recording:
      a. In the Ports Ports Ports Ports group, type a name to associate with the port number that you are adding. You can assign any name up to 40 characters.
      b. Type the port number to use with the computer's network name.
      c. Click Apply, then OK .
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  11. Click Close Close Close Close.
Read More Answers.

Question # 57
How to Recording a Single Script in a Session?

Answer:-
1.  In Robot, click the Record Session button. Alternatively, click File > Record Session, or press CTRL+SHIFT+R.
   2. Ty p e t h e session name (40 characters maximum), or accept the default name. You will specify the script name when you finish recording the script. If you
have not yet set your session recording options, do so now by clicking Options.
   3. Click OK in the Record Session - Enter Session Name dialog box. The following events occur:
      . Robot is minimized (default behavior).
      . The Session Record floating toolbar appears (default behavior). You can use this toolbar to stop recording, redisplay Robot, split a script, and insert features into
a script.
      . The Session Recorder icon appears on the taskbar. The icon blinks as Robot captures requests and responses.
   4. If the Start Application dialog box is displayed, provide the following information, and click OK:
      . The path of the executable file for the browser or database application.
      . Optionally, the working directory for any components (such as DLLs) that the client application needs at runtime.
      . Optionally, any arguments that you want to pass to the client application. The Start Application dialog box appears only if you are performing API recording, or
if you are performing network or proxy recording and selected Prompt for application name on start recording in the General tab of the Session Record Options dialog
box.
   5. Perform the transactions that you want to record. As the application sends requests to the server, notice the activity in the Session Recorder window. Progress
bars and request statistics appear in the top of the window.
      If there is no activity in the Session Recorder window (or if the Session Recorder icon never blinks), there is a problem with the recording. Stop recording and try
to find the cause of the problem.
   6. Optionally, insert features such as blocks and timers through the Session Insert floating toolbar or through the Robot Insert menu.
   7. Optionally, when you finish recording transactions, close the client application. With API recording, when you close the client, Robot asks whether you want to
stop recording. If so, click Yes, and either name the session or click to ignore the recorded information in the Generating Scripts dialog box.
   8. Click the Stop Recording button on the Session Record floating toolbar.
Read More Answers.

Question # 58
How to stop recording and generate scripts in a Session?

Answer:-
1. Click the Stop Recording button on the Session Record floating toolbar.
2. In the Name of the just-recorded script box, type or select a name for the script that you just finished recording, or accept the default name.
3. Click OK.
Read More Answers.

Question # 59
How to see error message If problems occur during script generation?

Answer:-
the error message appears in the status bar of the Generating Scripts dialog box like this: "Completed with warnings and/or errors"
To see the list of errors, click Details. If the text of an error is truncated, you can either:
. Double-click the text to see the entire message.
. Press CTRL+C to copy the text to the Clipboard.
Read More Answers.

Question # 60
How to cancelling a Script in a Single-Script Session?

Answer:-
1. During recording, click the Stop button on the Session Record floating toolbar.
2. In the Stop Recording dialog box, click Ignore just-recorded information.
3. Click OK in the Stop Recording dialog box.
4. Click OK to acknowledge that the session is being deleted.
Read More Answers.

Question # 61
When would you want to split a session?

Answer:-
If quick script development time is a priority - perhaps because testable builds are developed daily, or because web content is updated daily.
Read More Answers.

Question # 62
How to split a session into multiple scripts?

Answer:-
1. During recording, at the point where you want to end one script and begin a new one, click the Split Script button on the Session Record floating toolbar.
2. Enter a name for the script that you are ending, or accept the default name.
3. Click OK.
4. Repeat the previous steps as many times as needed to end one script and begin another. 5. After you click the Stop Recording button to end the recording session,
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type or select a name for the last script you recorded, or accept the default name.
Read More Answers.

Question # 63
How to regenerate Scripts from a Session?

Answer:-
1. In Robot, click Tools > Regenerate Test Scripts from Session.
2. Click the name of the session to use.
3. Click OK to acknowledge that the regeneration operation is complete.
Read More Answers.

Question # 64
How Timers Work?

Answer:-
1. Start the timer (click Insert--Start Timer) just before you click the button to send the query. This action inserts the VU emulation command start_time into the
script.
2. Stop the timer (click Insert --Stop Timer) as soon as the results appear. This action inserts the VU emulation command stop_time into the script.
Read More Answers.

Question # 65
What is a block?

Answer:-
A block is a set of contiguous lines of code that you want to make distinct from the rest of the script. Typically, you use a block to identify a transaction within a
script.
Read More Answers.

Question # 66
What is a blocks characteristics?

Answer:-
#  A block begins with the comment. In the VU language, a block begins like this:
/* Start_Block "BlockName" */
# Robot automatically starts a timer at the start of the block. In the VU language, the timer looks like this:
start_time ["BlockName"] _fs_ts;
Typically, the start_time emulation command is inserted after the first action, but with an argument to use a read-only variable that refers to the start of the first
action.
# The ID of every emulation command in a block is constructed the same way that is, by the block name followed by a unique, three-digit autonumber. For example,
in the VU language:
http_header_recv ["BlockName002"] 200;
When you end a block, command IDs are constructed as they were before you started the block. For example, if the last command ID before the block was Script025,
the next command ID after the block will be Script026.
# A block ends with a stop_time command plus a comment. For example, in the VU language:
stop_time ["BlockName"]; /* Stop_Block */
Read More Answers.

Question # 67
Why Use Blocks?

Answer:-
. To associate the block and timer names with the emulation command that performs the transaction.
. To include the block name in TestManager reports, thus enabling you to filter the reports with the block name.
.To make the script easier to read, and to provide an immediate context for a line within the block through command IDs.
Read More Answers.

Question # 68
How to insert a block into a script?

Answer:-
1.  If the Session Insert floating toolbar is not already displayed, click the Insert button on the Session Record floating toolbar.
   2. Click the Start Block button at that point in the script where you want the block to begin for example, just before you start to record a transaction.
   3. Type the block name. Robot uses this name as the prefix for all command IDs in the block. The maximum number of characters for a command ID prefix is
seven.
   4. Click OK.
   5. Record all of the client requests in the block.
   6. Click the Stop Block button to end the current block, and click OK.
   7. Continue recording the other sections of the script. When you start and stop a block during recording, the commands are reported as annotations in the
Annotations window.
Read More Answers.

Question # 69
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What is A synchronization point?

Answer:-
A synchronization point lets you coordinate the activities of a number of virtual testers by pausing the execution of each tester at a particular point
Read More Answers.

Question # 70
Why Use Synchronization Points?

Answer:-
By synchronizing virtual testers to perform the same activity at the same time, you can make that activity occur at some particular point of interest in your test.
Typically, synchronization points that you insert into scripts are used in conjunction with timers to determine the effect of varying workload on the timed activity.
Read More Answers.

Question # 71
How to set GUI playback options?

Answer:-
. Open the GUI Playback Options dialog box by doing one of the following:
. Before you start playback, click Tools > GUI Playback Options.
. Start playback by clicking the Playback Script button on the toolbar. In the Playback dialog box, click Options.
Read More Answers.

Question # 72
How to setting Log Options for Playback?

Answer:-
1.  Open the GUI Playback Options dialog box.
   2. Click the Log tab.
   3. To output the playback results to the log so you can view them, select Output playback results to log.
   4. To have the log appear automatically after playback is complete, select View log after playback. If you clear this, you can still view the log after playback by
clicking Tools > Rational Test > TestManager, and then opening the log.
   5. To have Robot prompt you before it overwrites a log, select Prompt before overwrite log.
   6. Click one of the following: Specify log information at playback , displays the Specify Log Information dialog box so that you can specify the build, log folder,
and log. Use default log information At playback, uses the same build and log folder that was used during the last playback. Uses the script name as the log name.
   7. Click OK or change other options.
Read More Answers.

Question # 73
How to set the wait state options?

Answer:-
1. Open the GUI Playback Options dialog box.
2. Click the Wai t State tab.
3. To specify how often Robot checks for the existence of a window, type a number in the Retry test every box.
4. To specify how long Robot waits for a window before it times out, type a number in the Timeout after box.
5. Click OK or change other options.
Read More Answers.

Question # 74
How to set Error Recovery Options?

Answer:-
Use the error recovery options to specify how Robot handles script command failures and verification point failures.
   1. Open the GUI Playback Options dialog box.
   2. Click the Error Recovery tab.
   3. To specify what Robot should do if it encounters a failure, click one of the following options under both On script command failure and On verification point
failure:
      Continue execution - Continues playback of the script.
      Skip current script - Terminates playback of the current script. If the script with the failure was called from another script, playback resumes with the command
following the CallScript command.
      Abort playback - Terminates playback of the current script. If the script with the failure was called from another script, the calling script also terminates.
   4. Click OK or change other options.
Read More Answers.

Question # 75
What is an unexpected active window?

Answer:-
An unexpected active window is any unplanned window that appears during script playback that prevents the expected window from being made active (for example,
an error message from the network or application-under-test). These windows can interrupt playback and cause false failures.
Read More Answers.

Question # 76
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Why setting the Diagnostic Tools Options?

Answer:-
You can use the Rational diagnostic tools - Rational Purify, Quantify, and PureCoverage - to collect diagnostic information about an application during playback of a
Robot script.
After playback, Robot can integrate the diagnostic tool's results into the Robot log, so that you can view all of the playback results in one place. You can choose to
show any combination of errors, warnings, and informational messages. You can then double-click a result in the log to open the script in Robot and the appropriate
file in the diagnostic tool.
Read More Answers.

Question # 77
What is the Trap?

Answer:-
Robot uses the Trap utility to detect the occurrence of General Protection Faults (GPF) and the location of offending function calls during playback. If a GPF is
detected, Robot updates a log file that provides information about the state of the Windows session that was running.
Read More Answers.

Question # 78
How to play back a GUI script?

Answer:-
1. Prepare for playback by restoring the test environment.
2. Set your playback options. You can also set these options after you start playback.
3. Click the Playback Script button on the toolbar.
4. Type a name or select it from the list.
5. To change the playback options, click GUI Options. When finished, click OK.
6. Click OK to continue.
7. If the Specify Log Information dialog box appears, fill in the dialog box and click OK.
8. If a prompt appears asking if you want to overwrite the log, do one of the following:
.Click Yes to overwrite the log.
.Click No to return to the Specify Log Information dialog box. Change the build, log folder, and/or log information.
.Click Cancel to cancel the playback.
Read More Answers.

Question # 79
What is a Datapool?

Answer:-
A datapool is a test dataset. It supplies data values to the variables in a script during script playback. Datapool's should be considered whenever multiple records are
being sent to the server in a single playback, and you want to send a different record each time.
Read More Answers.

Question # 80
What Kinds of Problems Does a Datapool Solve?

Answer:-
1.Problem: During recording, you create a personnel file for a new employee, using the employee's unique social security number. Each time the script is played back,
there is an attempt to create the same personnel file and supply the same social security number. The application rejects the duplicate requests.
Solution: Use a datapool to send different employee data, including unique social security numbers, to the server each time the script is played back.
2. Problem: You delete a record during recording. During playback, each instance and iteration of the script attempts to delete the same record, and Record Not Found
errors result.
Solution: Use a datapool to reference a different record in the deletion request each time the script is played back.
3. Problem: The client application reads a database record while you record a script for a performance test. During playback, that same record is read hundreds of
times. Because the client application is well designed, it puts the record in cache memory, making its retrieval deceptively fast in subsequent fetches. The response
times that the performance test yields will be inaccurate.
Solution: Use a datapool to request a different record each time the script is played back.
Read More Answers.

Question # 81
How to creating a Datapool with Robot?

Answer:-
1. Plan the Datapool
- What datapool columns do you need?
- What data type should you assign to each column?
- Do you need to create data types?
2. Generate the code
- Manually add datapool commands to the script
- Match up script variable names with datapool columns
3. Create and Populate the Datapool
- In TestManager, define datapool columns (including assign a data type to each datapool column).
- Generate the data.
- Verify generated data is correct (open back up to view)
- Test with script
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Read More Answers.

Question # 82
How to view or edit a datapools values while in Robot?

Answer:-
1.  If the script that will access the datapool is not open for editing, click File > Open > Test Script to open it.
   2. Click Edit > Datapool Information to open the Configure Datapool in Test Script dialog box.
   3. Either accept the defaults in the Configure Datapool in Test Script dialog box, or make any appropriate changes.
   4. When finished making any changes, click Save.
   5. Click Edit Existing Data.
   6. In the Edit Datapool dialog box, edit datapool values as appropriate.
   7. When finished editing datapool values, click Save, and then click Close.
Read More Answers.

Question # 83
How to Define and populate the datapool?

Answer:-
1.  To insert one or more new columns into the datapool file:
      a. Click the row located either just before or just after the location where you want to insert the new datapool column. (Note that the order in which datapool
column names are listed in Name determines the order in which values are stored in a datapool record.)
      An arrow appears next to the name of the datapool row you clicked.
      b. Click either Insert before or Insert after, depending on where you want to insert the datapool column.
      c. Type a name for the new datapool column (40 characters maximum).
      Make sure there is a script variable of the same name listed in the Configure Datapool in Test Script dialog box. The case of the names must match.
   2. For each datapool column in the grid, assign a data type to the column, and modify the default property values for the column as appropriate.
   3. When finished defining datapool columns, type a number in the No. of records to generate field.
      If a different row has to be retrieved with each fetch, make sure the datapool has at least as many rows as the number of users (and user iterations) that will be
requesting rows at runtime.
   4. Click Generate Data.
      You cannot generate data for a datapool that has more than 150 columns. Alternatively, if you do not want to generate any data now, click Save to save your
datapool column definitions, and then click Close.
   5. Optionally, click Yes to see a brief summary of the generated data.
Read More Answers.

Question # 84
How to test an HTML elements data?

Answer:-
1.  Start recording in Robot.
   2. Navigate to the Web page that contains the elements to test. For example, navigate to the page that is returned after the user submits a page to be processed.
   3. Click the Object Data Verification Point button on the GUI Insert toolbar.
   4. Assign a name, wait state, and expected result for the verification point and then click OK.
   5. In the Select Object dialog box, drag the Object Finder tool over the page until the element that you want to test appears in the TestTip.
   6. Release the mouse button and click OK.
   7. If the Object Data Test dialog box appears, select the data test to use and click OK.
   8. Select the verification method that Robot should use to compare the baseline data captured while recording with the data captured during playback.
   9. Click OK.
  10. When finished, click the Stop Recording button on the GUI Record toolbar.
Read More Answers.

Question # 85
How to Test for Text within a Table?

Answer:-
1. Add an Object Data verification point.
2. Select the HTMLTable object with the Object Finder tool.
3. Select a Contents data test.
4. Select the Case Sensitive verification method to test for all of the text in the table. Select the Find Sub String Case Sensitive verification method to test for any text
item with the table.
Read More Answers.

Question # 86
How to Test the Destination of a Link?

Answer:-
1. Add an Object Data verification point.
2. With the Object Finder tool, select HTMLLink to test a text-based link.
3. Select a Contents data test to capture the URL of the destination.
4. Select the Case Sensitive verification method to test for the entire URL. Select the Find Sub String Case Sensitive verification method to test for part of the URL.
Read More Answers.

Question # 87
How to test an HTML elements properties?
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Answer:-
1. Start recording in Robot.
2. Navigate to the Web page that contains the element to test.
3. Click the Object Properties Verification Point button on the GUI Insert toolbar.
4. Assign a name, wait state, and expected result for the verification point and then click OK,
5. Select the element to test and then click OK.
6. Click OK to insert the verification point.
Read More Answers.

Question # 88
How to verify that the Java extension is loaded?

Answer:-
1. Start Robot.
2. Click Tools > Extension Manager.
3. Verify that Java is selected. If not, select it.
4. To improve the performance of Robot, clear the check boxes of all environments that you do not plan to test.
5. Exit Robot.
Read More Answers.

Question # 89
How to test a Java component's data?

Answer:-
1. Start recording in Robot.
2. Open the Java applet or application that you want to test.
3. Navigate to the page that you want to test.
4. Start creating the Object Data verification point.
5. Assign a name, wait state, and expected result for the verification point and then click OK.
6. In the Select Object dialog box, drag the Object Finder tool over the page until the component you want to test appears in the TestTip.
7. Release the mouse button.
8. If the dialog box is still open, click OK.
9. If the Object Data Tests dialog box appears, select the data test to use and click OK.
10. Complete the verification point as usual.
Read More Answers.

Question # 90
How to create or edit a custom data test?

Answer:-
1. Display the object for which you want to create the data test.
2. In Robot, click Tools > Object Data Test Definition.
3. Click Select to open the Select Object dialog box.
4. Select the object for which you want to create the data test in one of the following ways:
-- Drag the Object Finder tool over the object and release the mouse button. As you move the Object Finder tool over an object, the object type appears in the yellow
TestTip.
-- Click Browse to open the Object List dialog box, select the object from the list, and click OK.
The Object List dialog box shows a hierarchical list of all objects on the Windows desktop, including hidden objects.
5. If the Select Object dialog box is still open, click OK to close it. The object classification of the selected object and its data tests appear in the Object Data Test
Definition dialog box.
If the object is Unknown (not defined), the Define Object dialog box appears. Select an object type and click OK to open the Object Data Test Definition dialog box.
6. Do one of the following to display the Create/Edit Object Data Test dialog box:
-- To create a new test, type a name (50 characters maximum) in the Data test name box and click New.
-- To edit a custom test, select the test from the list and click Edit.
-- To copy a test and edit the copy, select the test and click Copy. Type the new name and click OK. Then, click Edit.
7. Select a property from the Property to test list. This property is the one whose values you want to capture in the data test. 8. Select the Column check box to add
parameters for the vertical axis. Select the Row check box to add parameters for the horizontal axis.
9. Type an expression in the From and To boxes, or click the Expression button to the right of each box to build the expression.
An expression is a single value or property, or a combination of values, properties, and operators.
10. In the Using box (in the Create/Edit Object Data Test dialog box), type a property or select it from the list to further define the property that you are capturing and
testing.
The Using box specifies what property Robot will modify to affect its iteration. For example, to iterate from row 0 to row Rows-1, Robot will set the Row property.
11. Select the check boxes under Additional parameters as needed.
12. In the Description box, type a description that indicates what the data test does.
13. Optionally, click Te s t to do the following:
--Verify the syntax of the data test before you save it.
-- If the syntax is correct, watch Robot perform the data test on the selected object.
When the test has ended, Robot opens a dialog box with the captured data. Click OK to close the dialog box.
14. Click OK to save the test and automatically verify it.
If the syntax of the expression is incorrect, the incorrect area is highlighted so you can correct it and then resave the test.
Read More Answers.

Question # 91
What is Rational Suite?

Answer:-
Rational Suite is a set of tools for every member of the software development team. It contains the following tools:
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    * Rational Unified Process
    * Rational RequisitePro
    * Rational ClearQuest
    * Rational SoDA
    * Rational ClearCase LT
    * Rational TestManager
    * Rational ProjectConsole
    * Rational Rose
    * Rational PureCoverage
    * Rational Purify
    * Rational Quantify
    * Rational Robot
    * Rational TestFactory
    * Rational Process Workbench
    * Rational NetDeploy
    * Rational SiteLoad 
Rational tools are sold with the following packages:
    * Team Unifying Platform - Rational Unified Process, Rational RequisitePro, Rational ClearQuest, Rational SoDA, Rational ClearCase LT, Rational TestManager,
and Rational ProjectConsole.
    * Analyst Studio - Team Unifying Platform, and Rational Rose.
    * DevelopmentStudio - Team Unifying Platform, Rational RoseÂ£Â¬Rational PureCoverageÂ£Â¬Rational Purify, and Rational Quantify.
    * TestStudio - Team Unifying Platform, Rational PureCoverageÂ£Â¬Rational Purify, Rational Quantify, Rational Robot, and Rational TestFactory.
    * Enterprise - Team Unifying Platform, Rational Rose, Rational PureCoverageÂ£Â¬Rational Purify, Rational Quantify, Rational Robot, Rational TestFactory, and
Process Workbench.
    * Content Studio - Team Unifying Platform, Rational NetDeploy, and Rational SiteLoad.
Read More Answers.

Question # 92
What Is the Rational Unified Process (RUP)?

Answer:-
RUP is a process framework for developing software that helps you:
    * Coordinate the developmental responsibilities of the entire development team.
    * Produce high-quality software.
    * Meet the needs of your users.
    * Work within a set schedule and budget.
    * Leverage new technologies.
Read More Answers.

Question # 93
How to define a test case?

Answer:-
A test case describes the testable and verifiable behavior in a system. A test case can also describe the extent to which you will test an area of the application. Existing
project artifacts, such as requirements, provide information about the application and can be used as test inputs for your test cases. TestManager provides built-in test
input types, but almost any artifact can be used as a test input.
For example, here's what the following artifacts offer as test inputs:
    * Requirements describe a condition or capability to which a system must conform.
    * Visual models provide a graphic representation of a system's structure and interrelationships.
Read More Answers.
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1 : MS Excel Frequently Asked Interview Questions and Answers Guide.

2 : AutoCAD Frequently Asked Interview Questions and Answers Guide.

3 : MATLAB Frequently Asked Interview Questions and Answers Guide.

4 : MS Office Frequently Asked Interview Questions and Answers Guide.

5 : MS Word Frequently Asked Interview Questions and Answers Guide.

6 : BEA Weblogic Frequently Asked Interview Questions and Answers Guide.

7 : Microsoft Access Frequently Asked Interview Questions and Answers Guide.

8 : OOAD Frequently Asked Interview Questions and Answers Guide.

9 : SilkTest Frequently Asked Interview Questions and Answers Guide.

10 : Bugzilla Frequently Asked Interview Questions and Answers Guide.
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