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Question # 1
How can we create a dynamic column name in Cognos?

Answer:-
Select Properties, and then click the Headers/Footers tab.
Read More Answers.

Question # 2
What is Cognos Powerhouse and what is it used for?

Answer:-
Cognos Powerhouse is High-Productivity Application Development Solutions equips you with high-productivity development environments for creating your
data-driven business solutions faster,whether for Web-based, client/server, or traditional terminal-based access. PowerHouse has gained a worldwide reputation for
productivity, reliability, performance, and flexibility.
Read More Answers.

Question # 3
What is the difference b/w macros and prompt?

Answer:-
Macro-A macro is a set of instructions that can run applications.Example : A macro can open your catalog,select a report(say for instance) convert that to another
format and export it to any specified location,provided the code (Program)is such.Prompt-A prompt specifies the manner in which data in the reports are to be
displayed.A Prompt can be defined at the catalog level either or during report generation.
Read More Answers.

Question # 4
Suppose you run a report with empty data, how will you inform the end user that it has no data while running the report in report studio? is it possible, if so how?

Answer:-
Add a list footer and a text messsage inside "No Data". create a booloean conditional variable "Test" with code "rownum()>0". Select the complete list footer and set
Style Variable, if Yes, Box Type of the List footer should be set to "none". This should work...RD
Read More Answers.

Question # 5
What is meant by Junk Dimension?

Answer:-
The junk dimension is simply a structure that provides a convenient place to store the junk attributes
Read More Answers.

Question # 6
In my report contain Product name, Amount, Country, Sales person.
I want to create one prompt: Sales Territory.( Ex: asia, US, UK, AUS), but territory column is not there in my model and source.
if u select the Asia in prompt page-ll Asian country results I want in report page.
I discussed with my friends and colleague, they told use the static choice function.
Still I face this problem. if u know please tell me?

Answer:-
Based on country column find out the territory.create territory column in model level. In my expectation we should hard code using case condition.
If u find any best answers please give me solution.
Read More Answers.
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Question # 7
How to crate cubes in transformer?

Answer:-
cubes are created using transformer.cubes can be viewed using powerplay.cubes has impromptu query definition (IQD) files as their sources.IQD files are generated
from cognos impromptu.IQD files contain ,how the data has to be retrieved through catalogs and logical databases.
To create a cube..
1) save the impromtu report as IQD file.(.IQD)
2)open transformer,go to file-new-ModelName(user defined)-datasourcename(DWH name),source type(select impromptu query definition)-local data file(browse the
IQD file save earlier)-check the auto design check box-clk finish-database logon wizard will be opened-enter userid and pwd to connect to the DB---clk log on---A
new model will be generated with Dimensionmap,Datasource,Measures,powercube(still cube is not created) and Logical DB(imported from IQD file).
If you select "Run Autodesign" option duting the NEWMODELWIZARD, transformer automatically creates a dimension map and a list of measures for you.even
though transformer analyzes the data before creating a dimension map and list of measures,many a time they may not be totally accurate.
To avoid this we need to create Dimensions manually.
3) Now create new Dimensions in the dimensionmap area as per the requirement.select Dimension Map--insert Dimension--name the dimension--Drag and drop
columns one below the other from data source(see that the columns are in a hierarchy,Bcoz cubes will be created on these columns with all the possibilities to
facilitate drilling,slicing and dicing operations)..check the diagram ,it is displayed empty..data will be shown once the cube is created..
4) go to "Run" and clk on create powercubes.Cube will be created.check the power cube area in the Model.you will observe a cube in that area.This cube can be
viewed in Poweplay.
This is one method of creating cube by using IQD file.
The another method of creating cube is my creating a MODEL from Architect and generating a CUBE from that MODEL.
Read More Answers.

Question # 8
What is catalog and types of catalogs in cagonos and which is better?

Answer:-
A catalog is a file containing the information (Database tables) that Impromptu users need to create reports.
* personal
* distributed
* shared
* secured
shared catalog is better
Read More Answers.

Question # 9
What Junk Dimension contains?

Answer:-
it contains the miscellaneous attributes such as flags , which does belong to the main dimension table.
for eg; In a sales order fact table ,some informations like,
web-order , whether this is a online order or not
new_cust , Is this person a new customer ?
verification , whether the order has been verified?
Read More Answers.

Question # 10
Please explain the different stages in creating a report in cognos report net?

Answer:-
Before creating any report in report net make sure you are have the planning information you need.
Creating a report involves following steps:
Specifying a package
Choose a package through cognos connection>report studio>Select a module from the list.
Choosing a report template
Create a empty report first,click one of the predefined report templates ,click OK.
Adding query items
In the insertable objects plane,select the query item that you want to add to report,drag it to the desired location.
Saving report
Save the report from file menu.
Running the report
Open the report that you want to run.
From the Tools menu, click Validate Report.
A message box appears indicating whether any errors were found in the report.
If you want to enable Design Mode Only filters defined in the package, from the File menu,
click Use Model Design Filters.
Use these filters to limit the amountOpen the report that you want to run.
From the Tools menu, click Validate Report.
A message box appears indicating whether any errors were found in the report.
If you want to enable Design Mode Only filters defined in the package, from the File menu,
Read More Answers.

Question # 11
What is the difference between a cascading report and drillthru report?why do we go for drill thru report?

Answer:-
Cascading report works based on the condition but drill thru work based on the data item what we select as a drill thru options
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Read More Answers.

Question # 12
What is drill down and slicing and dicing whats the difference between them?

Answer:-
Drilling lets you quickly move from one level of detail to another to explore different aspects of your business. Drilling down moves you down in the hierarchy;
drilling up moves you up in the hierarchy.
Slicing and Dicing
While you can drill to look at information at any level, you can slice and dice to select the exact information you want in your report.
Read More Answers.

Question # 13
Give me any example of semi and non additive measures?

Answer:-
Semi-Additive: Semi-additive facts are facts that can be summed up for some of the dimensions in the fact table, but not the others. Non-Additive: Non-additive facts
are facts that cannot be summed up for any of the dimensions present in the fact table. Current Balance and Profit Margin are the facts.Current Balance is a
semi-additive fact, as it makes sense to add them up for all accounts (what's the total current balance for all accounts in the bank?), but it does not make sense to add
them up through time (adding up all current balances for a given account for each day of the month does not give us any useful information). Profit Margin is a
non-additive fact, for it does not make sense to add them up for the account level or the day level.
Read More Answers.

Question # 14
What is difference between PAGE BREAK and Section Report?
What is Main Advantage Datawarehousing over Oracle?

Answer:-
Section-section is eliminate the duplicate recod.but report looking separate bluck.
setpagebreak means to display the reports in onepage. eg. suppose u create a list report ordermethod,orderyear,revenu
when u create section on ordermethod.it will eliminate the duplicate record.but when u apply the set pagebreakc.report display in onepage.like fax reports in
onepage,email reports in another page.this in cognos 8 querystudio.
Read More Answers.

Question # 15
What is Zero-foot print?
What are the other methods working as deployment functionality?

Answer:-
Cognos offers Portal Services that allow organizations to easily manage and display Cognos business intelligence, planning, and scorecarding in your existing
enterprise information portals. Including Cognos reports, analysis, dashboards, scorecards, and other capabilities drives higher returns in your information and portal
investments.
Cognos portals offer:
Zero Footprint: Cognos portals have no footprint on the user's desktop. Anyone inside or outside the organization with a Web browser can access and interact with
content.
Intuitive User Interface: No special training is required to use the portal. Standard browser interface actions-such as following hypertext links, copying, and
pasting-allow users to access and organize business intelligence content quickly and easily
Read More Answers.

Question # 16
How you drill from powerPLay to Impromptu? Explain all Steps?

Answer:-
go to tran former,
build the cube
right click on the cube and open properties
go to drill through tab and select your report from that browse option
Read More Answers.

Question # 17
What is the difference between enterprise data warehouse and data warehouse?

Answer:-
Big Organizations have a lot of diversified sources of data.There might be a dataware house exclusively for transport and others for data related to the project the
company runs.In such case the complete enterprise's(company's) date ware house is a big combination of all and is known the Enterprise data Warehouse(EDW)
Read More Answers.

Question # 18
what is meant by alternate drill down with ex?

Answer:-
Alternate drill down path means there will be two path to opt.For example- We will have time dimension now the client requirement is they want two type of year
-one is calender year(Jan-Dec) and another is fiscal year(Apr-Mar).
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Read More Answers.

Question # 19
How create measures and Demensions?

Answer:-
You can create measure once you import all the data into the data source.You can create measures and dimensions by draging the required source from datasource
into dimension map and measure tab.(need to find scope of measures for all the dimensions)
Read More Answers.

Question # 20
What is loop in frameworkmanager?

Answer:-
Loop: loop is a closed path (relation) that exists among 3 (or) more tables. For example, if we have '3' tables T1, T2, T3 then, a loop exists among these tables only
when we create joins in the following fashion:
Loop: T1 ---> T2 ---> T3 ---> T1
To resolve the above problem, we have to create a shortcut (or) Alias to the Table T1.
No Loop: T1 ---> T2 ---> T3 ---> Alias (or) Shortcut of T1
Read More Answers.

Question # 21
What you mean by Drill across and what is the difference between drill through, drill across?

Answer:-
Drill across means when you are moving from one report to another report like country in one report and States in another Report whereas if the report is using same
report from moving from country to state. In other when you are moving details level if you are using the different report it is drill across and if you are using same
report it is drill through.
Read More Answers.

Question # 22
How do add dynamic titles in PP?

Answer:-
PowerplayFrom format menu-->title, header & footer-->title-->insert report filename
Read More Answers.

Question # 23
What is the difference between group and associare?

Answer:-
Group: used to eliminate duplicate values in the report.
Association: used with grouped item that displays data only when the values are changed.
ProctLine ProductName Quantity Revenue
--------------------------------------------------------
Soaps LUX 100 1000
200 2000
300 3000
TIDE 100 1500
SHAMPOO GARNIER 100 4000
200 8000
SUNSILK 100 5000
--> Here, ProductLine is a grouped column and ProductName is an Associated column.
Read More Answers.

Question # 24
What is Cognos Visualizer and Cognos Scripting?

Answer:-
Visualizer is a representation of data cubes in a dashboard format. We can drill through to the ground level of a hierarchy as like in power play report but cannot add
or remove fields dynamically.
Cognos script editor : We can write cognos macros or programs in this tool and can fine tune or process some execution
Read More Answers.

Question # 25
How can create users and permissions in cognos?

Answer:-
n impromptu menu go to Catlog->User profiles -> userclass tab -> click on Creator ->u can give there folder access,table access,filters,Governor etc
you can crate users by using USERS PROFILE option......and you can give permissions using ROLE IN C8 and GOVERNERS in C7
Read More Answers.
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Question # 26
How can i schedule reports in cognos?

Answer:-
By using Cognos Schedular, one can schedule the running reports in Impromptu to execute and save it in desired format.
By using Cognos MACRO script language the reports can be executed and distributed to recipients by using mail applications.
Compiled Cognos MACROs can be scheduled using Cognos Schedular.
Read More Answers.

Question # 27
How can i test reports in cagonos?

Answer:-
In cognos report net by the validate report option a report can be tested. If there will be any error, it will specify the the error, unless it will give message -'report
specification is valid'.
After creating the report we will connect to the oracle and we will write the sql query and we will compare this 2 reports .
Read More Answers.

Question # 28
What are products of cognos?

Answer:-
Cognos 6.6 7.0,7.3(PowerPlay, Impromptu)--ReportNet1.0,1.1mr1, 1.1mr22---ReportNet 8.0(latest)IWR is use by Impromptu to publish reports, PPES is used by PP,
Cognos Connection is used by repornet. there are many other tools but these are the main.
Read More Answers.
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